Reti locali
 

Linux Debian (7.6) e D-Link DSL-2750B

massimo.peca@libero.it 25 Set 2014 12:13
Ciao a tutti,
ho un problema che non riesco a risolvere, pertanto vi chiedo cortesemente di
aiutarmi a capire dove sbaglio.
Premetto che non sono un esperto, pur usando linux, ormai, da diversi anni.
Un'amica mi ha chiesto di aiutarla a connettere il suo pc portatile, su cui ho
installato il debian in oggetto, al suo router (citato) a cui è già connesso
un altro pc fisso su cui gira windows 7 regolarmente, utilizzato per usare
internet.
Il mistero (per me) è che il pc portaile, pur accedendo correttamente alla rete
locale sia tramite il cavo che tramite wireless, non ne vuole sapere di accedere
ad Internet. La cosa diventa ancora più oscura (sempre, per me) se si considera
che amule installato sul portatile funziona correttamente, anche con ID alto
dopo aver aperto le porte necessarie sul router. Non ho cambiato altro.
Ho fatto (almeno, credo) tutte le verifiche necessarie sulla con*****urazione
del router, ma non ho trovato nessun parametro da con*****urare diversamente
dalle impostazioni standard. L'ho resettato alcune volte, ma il suo
comportamento è sempre lo stesso. Infostrada dice che per loro è tutto
regolare e non forniscono questo tipo di assistenza.
Il firewall del router è disattivato. Il DHCP assegna gli indirizzi senza
problemi.
Lo stesso pc portatile, a casa mia, con un router diverso funziona senza
difficoltà. Lo stesso accade con un altro pc portatile: il mio.
Che posso fare?
Grazie. Massimo
Andrea B. 25 Set 2014 12:40
Il 25/09/2014 12.13, massimo.peca@libero.it ha scritto:
> Ciao a tutti,
> ho un problema che non riesco a risolvere, pertanto vi chiedo cortesemente
> di aiutarmi a capire dove sbaglio.
> Premetto che non sono un esperto, pur usando linux, ormai, da diversi anni.
> Un'amica mi ha chiesto di aiutarla a connettere il suo pc portatile, su cui
> ho installato il debian in oggetto, al suo router (citato) a cui è già
> connesso un altro pc fisso su cui gira windows 7 regolarmente,
utilizzato
> per usare internet.
> Il mistero (per me) è che il pc portaile, pur accedendo correttamente alla
> rete locale sia tramite il cavo che tramite wireless, non ne vuole sapere
> di accedere ad Internet. La cosa diventa ancora più oscura (sempre, per me)
> se si considera che amule installato sul portatile funziona correttamente,
> anche con ID alto dopo aver aperto le porte necessarie sul router.
> Non ho cambiato altro.
> Ho fatto (almeno, credo) tutte le verifiche necessarie sulla con*****urazione
> del router, ma non ho trovato nessun parametro da con*****urare
diversamente
> dalle impostazioni standard. L'ho resettato alcune volte, ma il suo
> comportamento è sempre lo stesso. Infostrada dice che per loro è tutto
> regolare e non forniscono questo tipo di assistenza.
> Il firewall del router è disattivato. Il DHCP assegna gli indirizzi senza
> problemi.
> Lo stesso pc portatile, a casa mia, con un router diverso funziona senza
> difficoltà. Lo stesso accade con un altro pc portatile: il mio.
> Che posso fare?

Premesso che quei router sono dei cessi, forse il server dhcp non
fornisce abbastanza informazioni al client.
Controlla che default gateway e dns siano a posto.
GabrieleMax 25 Set 2014 13:52
> Premesso che quei router sono dei cessi, forse il server dhcp non
> fornisce abbastanza informazioni al client.
> Controlla che default gateway e dns siano a posto.

Anche secondo me il problema sono i dns, un dlink che ho in ufficio
fornisce in dhcp solo gli ip locali e non i dns, mi è capitato più volte
con vecchi router Alice tipo quelli bianchi con sole due porte eth che
non fornissero tutti i dati dhcp a pc con Linux a bordo!

Converrebbe provare anche ad aggiornare il firmware del router poi
conviene fare una prova editanto i files di con*****urazione di Debian
impostando ip statici ed i dns di Google, riavvio dei servizi di rete o
riavvio della macchina ed il gioco è (dovrebbe) esser fatto! :)

Comunque tanto di cappello per essere riuscito ad installare Debian ad
una ragazza immagino come desktop KDE! :)

Saluti!
GabrieleMax
Kim Allamandola 25 Set 2014 15:28
Se non dai qualche info in più non penso sia possibile rispondere... Per es.
posta l'output di:
ip -4 a
route -n
cat /etc/resolv.conf
come utente e
iptables -nL
come root

Questo chiarisce le impostazioni di rete che hai sulla Debian, in base a
queste si può vedere che fare, ad ogni modo per chi inizia e specie per
un desktop, senza voler far flame, Ubuntu è decisamente più consigliabile :-)

--
| sed s/_//g on my mail to reach me :-)
massimo.peca@libero.it 28 Set 2014 00:35
Il giorno giovedì 25 settembre 2014 15:28:51 UTC+2, Kim Allamandola ha scritto:
> Se non dai qualche info in più non penso sia possibile rispondere... Per es.
>
> posta l'output di:
>
> ip -4 a
eccoti servito:
ip -4 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
inet 127.0.0.1/8 scope host lo
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
inet 192.168.1.9/24 brd 192.168.1.255 scope global wlan0
4: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP
qlen 1000
inet 62.18.70.72/28 brd 62.18.70.79 scope global wwan0
>
> route -n
>
> cat /etc/resolv.conf
ip -4 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
inet 127.0.0.1/8 scope host lo
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
inet 192.168.1.9/24 brd 192.168.1.255 scope global wlan0
4: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP
qlen 1000
inet 62.18.70.72/28 brd 62.18.70.79 scope global wwan0

>
> come utente e
>
> iptables -nL
>
> come root
ip -4 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
inet 127.0.0.1/8 scope host lo
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
inet 192.168.1.9/24 brd 192.168.1.255 scope global wlan0
4: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP
qlen 1000
inet 62.18.70.72/28 brd 62.18.70.79 scope global wwan0

>
>
>
> Questo chiarisce le impostazioni di rete che hai sulla Debian, in base a
>
> queste si può vedere che fare, ad ogni modo per chi inizia e specie per
>
> un desktop, senza voler far flame, Ubuntu è decisamente più consigliabile
:-)
ti ringrazio, ma Ubuntu l'ho sempre trovato ostico.

ciao. massimno
Kim Allamandola 28 Set 2014 14:47
Hem, hai incollato solo ip -4 a, cmq già questo è strano: sei connesso via
WiFi alla lan e ad internet con una penna usb, non risultano connessioni
cablate. Per ora non posso dirti altro, posta anche
route -n
cat /etc/resolv.conf
tanto per vedere se la nic cablata è riconosciuta aggiungi anche ip link show

Solo perché hai scritto che non hai esperienza, visto l'output che hai
postato, solo come tarlo casuale senza volerti offendere: ogni riga è un
comando a se. Ovvero nel terminale scrivi "route -n" (senza virgolette) e
batti invio, copi l'output e scrivi cat /etc/resolv.conf ecc.

--
| sed s/_//g on my mail to reach me :-)
massimo.peca@libero.it 1 Ott 2014 00:10
Il 28/09/2014 14:47, Kim Allamandola ha scritto:> Hem, hai incollato solo ip -4
a,
scusa, hai ragione. Ecco l'output completo:

ip -4 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP
qlen 1000
inet 192.168.1.5/24 brd 192.168.1.255 scope global eth0
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000

inet 192.168.1.4/24 brd 192.168.1.255 scope global wlan0
root@casa02: ******* patrizia# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
root@casa02: ******* patrizia# cat /etc/resolv.conf
# Generated by NetworkManager
domain DSL2750B
search DSL2750B
nameserver 192.168.1.1
root@casa02: ******* patrizia# iptables -nL
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
root@casa02: ******* patrizia#

fatto. Che mi dici?


--
Saluti. Massimo Peca
Kim Allamandola 1 Ott 2014 02:02
Hum,
non c'è nulla di particolare da rilevare: le due nic (cablata e wifi) sono
connesse con indirizzi a naso giusti, il routing è ok... Posso suggerire
due prove: la prima super semplice: prova ad aprire http://173.194.113.247
è uno degli IP di Google search, se così navighi prova a piallare
/etc/resolv.conf scrivendoci solo

nameserver 208.67.222.222
nameserver 8.8.4.4

e vedi se così firefox&c navigano (nel caso dal NetworkManager imposta il
dhcp come "solo indirizzi" e metti i due ip come 208.67.222.222, 8.8.4.4),
se ancora non navigano controlla di non aver proxy impostati, magari dal DE.
Al momento non mi viene in mente altro...

--
| sed s/_//g on my mail to reach me :-)

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Reti locali | Tutti i gruppi | it.comp.reti.locali | Notizie e discussioni reti locali | Reti locali Mobile | Servizio di consultazione news.