Reti locali
 

Usare porta LAN come ingresso WAN?

edevils 13 Dic 2015 20:19
E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
da poter usare una delle porte LAN come fosse la WAN?
Lo scopo è usarlo in cascata col modem-router di Telecom Italia, non
però come semplice switch.
Il DGN3500 dispone di porta RJ11 DSL, non invece della porta WAN RJ45.
edevils 14 Dic 2015 10:13
On 13/12/2015 20:19, edevils wrote:
> E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
> da poter usare una delle porte LAN come fosse la WAN?
> Lo scopo è usarlo in cascata col modem-router di Telecom Italia, non
> però come semplice switch.
> Il DGN3500 dispone di porta RJ11 DSL, non invece della porta WAN RJ45.

Da alcune cose lette in rete, direi che no, non si può, ma tentar a
chiedere non nuoce :)
Andrea B. 14 Dic 2015 12:25
Il 14/12/2015 10.13, edevils ha scritto:
> On 13/12/2015 20:19, edevils wrote:
>> E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
>> da poter usare una delle porte LAN come fosse la WAN?
[..]

Se vuoi sfruttarne le capacità di firewalling no, non si può fare.
Gingillo 14 Dic 2015 14:02
"edevils" ha scritto nel messaggio news:n4kg75$rip$1@dont-email.me...

E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
da poter usare una delle porte LAN come fosse la WAN?
Lo scopo è usarlo in cascata col modem-router di Telecom Italia, non
però come semplice switch.
Il DGN3500 dispone di porta RJ11 DSL, non invece della porta WAN RJ45.



Non so con AMOD, ma con openwrt si puo' fare senza problemi.
edevils 14 Dic 2015 14:31
On 14/12/2015 14:02, Gingillo wrote:
>
>
> "edevils" ha scritto nel messaggio news:n4kg75$rip$1@dont-email.me...
>
> E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
> da poter usare una delle porte LAN come fosse la WAN?
> Lo scopo è usarlo in cascata col modem-router di Telecom Italia, non
> però come semplice switch.
> Il DGN3500 dispone di porta RJ11 DSL, non invece della porta WAN RJ45.
>
>
>
> Non so con AMOD, ma con openwrt si puo' fare senza problemi.

Bene! Avresti anche un riferimento per la procedura da seguire?


p.s. Quando avevo controllato su openwrt.org tempo fa non c'era ancora
un'immagine per dgn3500, ma ora mi pare ci sia qualcosa.
https://forum.openwrt.org/viewtopic.php?id=24195&p=7
edevils 14 Dic 2015 18:37
On 14/12/2015 14:02, Gingillo wrote:
>
>
> "edevils" ha scritto nel messaggio news:n4kg75$rip$1@dont-email.me...
>
> E' possibile configurare un Netgear DGN3500 (con firmware AMOD) in modo
> da poter usare una delle porte LAN come fosse la WAN?
> Lo scopo è usarlo in cascata col modem-router di Telecom Italia, non
> però come semplice switch.
> Il DGN3500 dispone di porta RJ11 DSL, non invece della porta WAN RJ45.
>
>
>
> Non so con AMOD, ma con openwrt si puo' fare senza problemi.

Per ora ho trovato indicazioni per un altro modello.
https://forum.openwrt.org/viewtopic.php?id=57305
ArchiPit 15 Dic 2015 12:53
Rispondo qui sotto a edevils


> p.s. Quando avevo controllato su openwrt.org tempo fa non c'era ancora
> un'immagine per dgn3500, ma ora mi pare ci sia qualcosa.
> https://forum.openwrt.org/viewtopic.php?id=24195&p=7

Ottima notizia, vado a vedere.
Ciao!
Gingillo 15 Dic 2015 17:55
"edevils" ha scritto nel messaggio news:n4mg7i$77l$1@dont-email.me...


Bene! Avresti anche un riferimento per la procedura da seguire?



Il DGN3500 e' ormai supportato anche dalla nuova 15.05 (Chaos Calmer).
Brevemente:

1) Flasha il firmware con l'apposita immagine
2) Configura l'os secondo le tue esigenze
3) In /etc/config/network adda:

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '3 5t'

(rimuovi la port 3 dalla sezione precedente 'switch0', in pratica diverrebbe
option ports '1 2 0 5t')
La porta 3 corrisponde alla porta 1 sul router, che collegherai a una delle
porte lan del router telecom.

Dopodiche', sempre nello stesso ******* definisci:

config interface 'wan'
option ifname 'eth0.2'
option proto 'pppoe'
option username '....'
option password '....'
altre options

Ricordati infine di settare le regole di firewalling per la nuova zona
creata (wan) e di configurare il forwarding lan-->wan nel *******
/etc/config/firewall.

At salut.
edevils 16 Dic 2015 16:42
On 15/12/2015 17:55, Gingillo wrote:

> Il DGN3500 e' ormai supportato anche dalla nuova 15.05 (Chaos Calmer).
> Brevemente:
>
> 1) Flasha il firmware con l'apposita immagine
> 2) Configura l'os secondo le tue esigenze
> 3) In /etc/config/network adda:
>
> config switch_vlan
> option device 'switch0'
> option vlan '2'
> option ports '3 5t'
>
> (rimuovi la port 3 dalla sezione precedente 'switch0', in pratica
> diverrebbe option ports '1 2 0 5t')
> La porta 3 corrisponde alla porta 1 sul router, che collegherai a una
> delle porte lan del router telecom.
>
> Dopodiche', sempre nello stesso ******* definisci:
>
> config interface 'wan'
> option ifname 'eth0.2'
> option proto 'pppoe'
> option username '....'
> option password '....'
> altre options
>
> Ricordati infine di settare le regole di firewalling per la nuova zona
> creata (wan) e di configurare il forwarding lan-->wan nel ******* >
/etc/config/firewall.
>
> At salut.


Grande! Poi ci provo :)
Sarebbe stato un peccato lasciarlo a prender polvere.

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Reti locali | Tutti i gruppi | it.comp.reti.locali | Notizie e discussioni reti locali | Reti locali Mobile | Servizio di consultazione news.