Reti locali
 

Uno switch che trolla!

Bowlingbpsl 13 Ott 2016 16:00
Mi ha fatto dannare per tre ore.
Magari a voi sembra b*****e, ma io non l'avevo mai nemmenos entito.

Mi chiamano, non va internet. Vediamo.

Il pc sembra a posto. Lo switch pure. Da browser, digito l'ip del router.
Il fritz risponde bene.
Ma il pc non esce su internet. DNS a posto (gugol). ADSL a posto. Da altro
PC tutto va.
Ci si mette il wifi, a trollarmi. Per un po', non andava. Poi va.
Non e' il router. L'avremo spento e riacceso almeno 5 volte.
Il ping non va da nessuna parte. Tracert nemmeno. Eh?

Tutto mi diceva "impossibile". Guardavo allibito il monitor. Praticamente,
arrivavo solo fino al router. Nessun filtro strano. Eh?

Il fatto che da altro PC andasse, su altro cavo di rete... e "tutti" gli
apparecchi collegati a "quello" switch, mi ha fatto sospettare.
Collego un lungo cavo di rete da router a switch. Ancora niente.
Disperato, collego il bancomat (LAN) direttamente sul router. Ve' che va.

ERA LO SWITCH!

Cambiato, tutto funziona a meraviglia.

Ora, qualche anima gentile mi spiega?
E' una settimana che penso: WTF?
(avevo dei piccoli problemi. A volte, il PC non si connetteva alla rete.
Disabilita/riabilita e tutto andava. Credevo fosse la scheda di rete
integrata nel PC...)

Mai sentito dire di problemi... selettivi.

Fabrizio
ilChierico 14 Ott 2016 10:32
On 13/10/2016 16:00, Bowlingbpsl wrote:

> Ora, qualche anima gentile mi spiega?

Si era rotta l'unica porta di quello switch che era collegata al PC
incriminato per caso?

Non hai provato a collegare quel PC ad un'altra porta di quello switch e
vedere che succedeva?
Bowlingbpsl 18 Ott 2016 18:53
ilChierico wrote:
> On 13/10/2016 16:00, Bowlingbpsl wrote:
>
>> Ora, qualche anima gentile mi spiega?
>
> Si era rotta l'unica porta di quello switch che era collegata al PC
> incriminato per caso?
>
> Non hai provato a collegare quel PC ad un'altra porta di quello
> switch e vedere che succedeva?

Tutte. Le ho provate TUTTE, quelle dannate porte. Ho pensato pure io ad
una porta rotta. No, non era quello il problema.
Era proprio "qualcosa d'altro".
Solo che, francamente, non ho capito che diavolo e' successo. Mi bloccava
il routing? Uno switch, "cosa fa" esattamente, per darmi questi problemi?
Non so, non sono cosi' competente e speravo che qualcuno mi dicesse "eh,
e' capitato anche a me, perche' (ecc ecc)"

Ancora ci penso.
(con lo switch funzionante, ora non perde un colpo)

Fabrizio
EvanMac 18 Ott 2016 20:39
Bowlingbpsl <bowling@people.it> wrote:

> Solo che, francamente, non ho capito che diavolo e' successo. Mi bloccava
> il routing? Uno switch, "cosa fa" esattamente, per darmi questi problemi?

ha una tabella ARP/RARP che associa il MAC address all'indirizzo IP

mi viene da pensare, così a naso, che per qualche motivo si fosse
"scassato" il firmware (o il chip su cui risiedeva) per cui non riusciva
più a fare il routing corretto usando quel MAC address

hai provato a cambiare scheda di rete, in modo da avere un altro MAC
address (va bene pure cambiare da cablata a wifi sullo stesso PC)?

altre idee? :D

--
this is a random signature
LC 19 Ott 2016 22:34
On 18/10/2016 18:53, Bowlingbpsl wrote:
> ilChierico wrote:
>> On 13/10/2016 16:00, Bowlingbpsl wrote:
>>
>>> Ora, qualche anima gentile mi spiega?
>>
>> Si era rotta l'unica porta di quello switch che era collegata al PC
>> incriminato per caso?
>>
>> Non hai provato a collegare quel PC ad un'altra porta di quello
>> switch e vedere che succedeva?
>
> Tutte. Le ho provate TUTTE, quelle dannate porte. Ho pensato pure io ad
> una porta rotta. No, non era quello il problema.
> Era proprio "qualcosa d'altro".
> Solo che, francamente, non ho capito che diavolo e' successo. Mi bloccava
> il routing? Uno switch, "cosa fa" esattamente, per darmi questi problemi?
> Non so, non sono cosi' competente e speravo che qualcuno mi dicesse "eh,
> e' capitato anche a me, perche' (ecc ecc)"
>
> Ancora ci penso.
> (con lo switch funzionante, ora non perde un colpo)
>
> Fabrizio
>
>
>
A me l'altra mattina un Cisco 3750 con L3 mi ha fatto una cosa simile.
mezza rete di una sede non andava (o meglio, non usciva dalla sua vlan),
il resto funzionava (fonia compresa).
Crash del S.O. con conseguente blocco dell'arp e mac address table vuota
(e non ho ancora capito se faceva flooding - boh). Ci ho messo un'oretta
buona prima di rendermene conto, perchè il fetente non dava indicazioni
palesi.
Scoperto essere un bug con richiesto reload e down di tutta la sede per
circa 5 minuti (in orario di punta per il tipo di lavoro).
Ma mi sa che nel tuo caso non era una roba simile..

--
Luca

"Unix is simple. It just takes a genius to understand its simplicity." -
Dennis Ritchie
ilChierico 21 Ott 2016 17:05
On 18/10/2016 18:53, Bowlingbpsl wrote:

> Solo che, francamente, non ho capito che diavolo e' successo. Mi bloccava
> il routing? Uno switch, "cosa fa" esattamente, per darmi questi problemi?
> Non so, non sono cosi' competente e speravo che qualcuno mi dicesse "eh,
> e' capitato anche a me, perche' (ecc ecc)"

Io ho ancora sulla scrivania uno switch-hub (mi han spiegato che è una
specie di ibrido che si usava forse perchè costava meno) ma lo switch
non dovrebbe far altro che rigenerare il segnale e morta lì.

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Reti locali | Tutti i gruppi | it.comp.reti.locali | Notizie e discussioni reti locali | Reti locali Mobile | Servizio di consultazione news.