Reti locali
 

Wake on wan

Robert@ne 29 Apr 2016 17:36
Buonasera a tutto il n.g.

Mi si presenta la possibilità di provare l'accensione del pc da remoto
avendo fatto attivare l'IP pubblico in prova fino a lunedì. Premetto che
l'accensione da rete (WOL) funziona senza problemi. Il router in uso è
un TP-LINK mod. TL-WR1043ND con firmware DD-WRT. Avevo già affrontato
tempo fa questo argomento tralasciando l'accensione da remoto in quanto
sprovvisto di IP pubblico. Morale, non riesco da remoto accendere il pc,
non so se il problema sia dato dal tentativo di effettuare il WOW da
smartphone con gestore Wind, oppure dei settaggi errati nel router.
Chiedo lumi.

Grazie.

Roberto
angelo 29 Apr 2016 18:56
Il 29/04/2016 17:36, Robert@ne ha scritto:
> Buonasera a tutto il n.g.
>
> Mi si presenta la possibilità di provare l'accensione del pc da remoto avendo
fatto
> attivare l'IP pubblico in prova fino a lunedì. Premetto che l'accensione da
rete (WOL)
> funziona senza problemi. Il router in uso è un TP-LINK mod. TL-WR1043ND con
firmware
> DD-WRT. Avevo già affrontato tempo fa questo argomento tralasciando
l'accensione da remoto
> in quanto sprovvisto di IP pubblico. Morale, non riesco da remoto accendere il
pc, non so
> se il problema sia dato dal tentativo di effettuare il WOW da smartphone con
gestore Wind,
> oppure dei settaggi errati nel router. Chiedo lumi.
>
> Grazie.
>
> Roberto
>
>

Per cominciare puoi fare una verifica lanciando il comando da questo sito:

https://www.depicus.com/wake-on-lan/woli

per verificare se le impostazioni sono corrette.

angelo
Robert@ne 29 Apr 2016 20:00
Il 29/04/2016 18:56, angelo ha scritto:

>
> Per cominciare puoi fare una verifica lanciando il comando da questo sito:
>
> https://www.depicus.com/wake-on-lan/woli
>
> per verificare se le impostazioni sono corrette.
>
> angelo


Grazie Angelo.

Sei stato proprio tu qualche anno fa a dirmi come impostare il tutto per
il wol...

Ho fatto la prova succitata e ricevo questo messaggio:

Ultimo accesso: mar 12 mag 10:10:50 on ttys000
depicus: ~ $ web Un pacchetto magico (00-1A-92-B1-10-99) di 102 byte è
stato inviato tramite UDP all'indirizzo IP: 192.168.0.2: 9.

L'indirizzo MAC impostato è quello del pc, o dev'essere del router?

Grazie

Roberto
angelo 29 Apr 2016 21:00
Il 29/04/2016 20:00, Robert@ne ha scritto:
> Grazie Angelo.
>
> Sei stato proprio tu qualche anno fa a dirmi come impostare il tutto per il
wol...
>
> Ho fatto la prova succitata e ricevo questo messaggio:
>
> Ultimo accesso: mar 12 mag 10:10:50 on ttys000
> depicus: ~ $ web Un pacchetto magico (00-1A-92-B1-10-99) di 102 byte è stato
inviato
> tramite UDP all'indirizzo IP: 192.168.0.2: 9.
>
> L'indirizzo MAC impostato è quello del pc, o dev'essere del router?
>
> Grazie
>
> Roberto

Il MAC deve essere quello del PC da svegliare, "ip address or fqdn" deve essere
l'indirizzo IP pubblico che ti e' stato assegnato oppure il nome host che hai
impostato
per il DDNS, la porta UDP e' quella che hai impostato sul router per l'inoltro
in LAN.
A proposito come hai configurato il router per l'inoltro del pacchetto?

angelo
Robert@ne 29 Apr 2016 21:33
Il 29/04/2016 21:00, angelo ha scritto:

>
> Il MAC deve essere quello del PC da svegliare, "ip address or fqdn" deve
> essere l'indirizzo IP pubblico che ti e' stato assegnato oppure il nome
> host che hai impostato per il DDNS, la porta UDP e' quella che hai
> impostato sul router per l'inoltro in LAN.
> A proposito come hai configurato il router per l'inoltro del pacchetto?
>
> angelo

Il router, alla voce forwarding port, l'ho configurato così nell'ultimo
tentativo:

Protocollo: UDP dalla porta 9 alla porta 9
Source net: 192.168.0.2 (Ip abilitato dal gestore)
Indirizzo IP: 192.168.1.255


Ho grossi dubbi...

Rob.
angelo 29 Apr 2016 22:26
Il 29/04/2016 21:33, Robert@ne ha scritto:
>
> Il router, alla voce forwarding port, l'ho configurato così nell'ultimo
tentativo:
>
> Protocollo: UDP dalla porta 9 alla porta 9
> Source net: 192.168.0.2 (Ip abilitato dal gestore)
> Indirizzo IP: 192.168.1.255
>
>
> Ho grossi dubbi...
>
> Rob.

Nella pagina di forward di dd-wrt non c'e' il source net, in quale pagina si
trova?
Peraltro l'indirizzo 192.168.0.2 non e' un indirizzo IP pubblico, quello lo puoi
ottenere qui:
http://www.hashemian.com/whoami/
Poi dalle prove che avevo fatto i pacchetti non vengono inoltrati all'indirizzo
192.168.1.255

angelo
Robert@ne 30 Apr 2016 00:18
Il 29/04/2016 22:26, angelo ha scritto:

>
> Nella pagina di forward di dd-wrt non c'e' il source net, in quale
> pagina si trova?
> Peraltro l'indirizzo 192.168.0.2 non e' un indirizzo IP pubblico, quello
> lo puoi ottenere qui:
> http://www.hashemian.com/whoami/
> Poi dalle prove che avevo fatto i pacchetti non vengono inoltrati
> all'indirizzo 192.168.1.255
>
> angelo


Si c'è

Questa è la ******* effettuata col provider in WhatsApp per quanto concerne
l'IP:
Buongiorno, ci può comuncare l'indirizzo IP dove deve essere aperto ip
pubblico??
89.150.36.235
Quello interno. L'indirizzo IP interno!!
Sorry
Se non erro è questo: WAN IP: 192.168.0.2


Non so se ho sbagliato a comunicare l'indirizzo IP spero di no...

Rob.
angelo 30 Apr 2016 07:33
Il 30/04/2016 00:18, Robert@ne ha scritto:

> Si c'è
>
> Questa è la ******* effettuata col provider in WhatsApp per quanto concerne
l'IP:
> Buongiorno, ci può comuncare l'indirizzo IP dove deve essere aperto ip
pubblico??
> 89.150.36.235
> Quello interno. L'indirizzo IP interno!!
> Sorry
> Se non erro è questo: WAN IP: 192.168.0.2
>
>
> Non so se ho sbagliato a comunicare l'indirizzo IP spero di no...
>
> Rob.

Allora come indirizzo source devi mettere 0.0.0.0 (cioe' "qualsiasi indirizzo")
altrimenti
ti accetta solo pacchetti provenienti dall'indirizzo che metti.

angelo
Robert@ne 30 Apr 2016 11:27
Il 30/04/2016 07:33, angelo ha scritto:
> Il 30/04/2016 00:18, Robert@ne ha scritto:
>

>
> Allora come indirizzo source devi mettere 0.0.0.0 (cioe' "qualsiasi
> indirizzo") altrimenti ti accetta solo pacchetti provenienti
> dall'indirizzo che metti.
>
> angelo

Ciao Angelo.

Non pensavo che la procedura fosse così ardua per il semplice fatto che
il WOL mi funziona senza problemi, anche da smartphone collegato in rete
a mezzo WiFi, idem da tablet, idem da un altro pc collegato in rete
sempre in WiFi.

Ho provato ad impostare il Forwarding port in questo modo:

Protocollo UDP
Source net 0.0.0.0 come mi avevi detto
Dalla porta 7
Indirizzo IP: quì ho fatto svariate prove, dal 192.168.0.2 al 89.150.36.235
Alla porta 7 ed ho flaggato su abilita.

Non succede nulla... Non so se ci sia qualche altro parametro da
impostare, il provider mi ha rassicurato di aver attivato l'IP pubblico.

Essendo testardo, ho smanettato fino alle 3,15 senza nessun risultato.

Grazie.

Rob.
angelo 30 Apr 2016 18:05
Il 30/04/2016 11:27, Robert@ne ha scritto:

>
> Ciao Angelo.
>
> Non pensavo che la procedura fosse così ardua per il semplice fatto che il
WOL mi funziona
> senza problemi, anche da smartphone collegato in rete a mezzo WiFi, idem da
tablet, idem
> da un altro pc collegato in rete sempre in WiFi.
>
> Ho provato ad impostare il Forwarding port in questo modo:
>
> Protocollo UDP
> Source net 0.0.0.0 come mi avevi detto
> Dalla porta 7
> Indirizzo IP: quì ho fatto svariate prove, dal 192.168.0.2 al 89.150.36.235
> Alla porta 7 ed ho flaggato su abilita.
>
> Non succede nulla... Non so se ci sia qualche altro parametro da impostare, il
provider mi
> ha rassicurato di aver attivato l'IP pubblico.
>
> Essendo testardo, ho smanettato fino alle 3,15 senza nessun risultato.
>
> Grazie.
>
> Rob.

Quello che ti serve e' fare in modo che il pacchetto arrivi al tuo router e che
venga
inoltrato nella tua LAN e venga trasmesso in broadcast.
Per fare questo devi:
creare un host virtuale che abbia un indirizzo IP a tua scelta e MAC
ff:ff:ff:ff:ff cosi'
ogni pacchetto indirizzato a lui viene trasmesso in broadcast.
Per creare questo host devi aggiungere un record ARP con un comando tipo:
arp -s 192.168.1.10 FF:FF:FF:FF:FF:FF
che scriverai nella finestra "Amministrazione-Comandi-Shell dei comandi" poi
clicchi su
"Salva Startup", in tal modo all'avvio viene aggiunto il record ARP.
Per verificare, dopo il riavvio, scrivi "arp" sempre nella finestra di cui sopra
e clicchi
su "Esegui Comandi", ti compare qualcosa del genere:
? (192.168.1.10) at FF:FF:FF:FF:FF:FF [ether] PERM on br0
Adesso devi aggiungere la regola di forwarding della porta 7 UDP all'indirizzo
192.168.1.10 e poi provi a lanciare il comando WOL dal sito
https://www.depicus.com/wake-on-lan/woli
mettendo il MAC del pc da svegliare, tuo indirizzo IP pubblico (89.150.36.235) e
la porta n.7.
Non dimenticare di incrociare le dita...

angelo
angelo 30 Apr 2016 18:09
> ...
> creare un host virtuale che abbia un indirizzo IP a tua scelta e MAC
ff:ff:ff:ff:ff

o meglio:
........ e MAC ff:ff:ff:ff:ff:ff
Robert@ne 30 Apr 2016 19:05
Il 30/04/2016 18:05, angelo ha scritto:

>
> Quello che ti serve e' fare in modo che il pacchetto arrivi al tuo
> router e che venga inoltrato nella tua LAN e venga trasmesso in broadcast.
> Per fare questo devi:
> creare un host virtuale che abbia un indirizzo IP a tua scelta e MAC
> ff:ff:ff:ff:ff cosi' ogni pacchetto indirizzato a lui viene trasmesso in
> broadcast.
> Per creare questo host devi aggiungere un record ARP con un comando tipo:
> arp -s 192.168.1.10 FF:FF:FF:FF:FF:FF
> che scriverai nella finestra "Amministrazione-Comandi-Shell dei comandi"
> poi clicchi su "Salva Startup", in tal modo all'avvio viene aggiunto il
> record ARP.
> Per verificare, dopo il riavvio, scrivi "arp" sempre nella finestra di
> cui sopra e clicchi su "Esegui Comandi", ti compare qualcosa del genere:
> ? (192.168.1.10) at FF:FF:FF:FF:FF:FF [ether] PERM on br0
> Adesso devi aggiungere la regola di forwarding della porta 7 UDP
> all'indirizzo 192.168.1.10 e poi provi a lanciare il comando WOL dal sito
> https://www.depicus.com/wake-on-lan/woli
> mettendo il MAC del pc da svegliare, tuo indirizzo IP pubblico
> (89.150.36.235) e la porta n.7.
> Non dimenticare di incrociare le dita...
>
> angelo


Ciao Angelo.

Ho creato l'host virtuale come da tue istruzioni. Ho dato il comando arp
ed ho ricevuto regolare risposta. Ho provato a lanciare il WOL dal sito
che mi indichi ma niente da fare. Non vorrei che dipendesse
dall'impostazione sul Forwarding delle porte. I parametri che mi chiede
sono questi:

Applicazione, Protocollo, Source Net, Dalla Porta, Indirizzo IP,Alla
Porta, Abilita


Ho provato in vari modi non avendo le idee chiare ma nulla da fare. Ho
incrociato di tutto ma non si vuole svegliare sto ******* Quello che
mi fa arrabbiare è che da LAN tutto funziona, perciò mi fa pensare che
la strada da percorrere sia breve, ma non la trovo!

Rob.
angelo 30 Apr 2016 19:35
Il 30/04/2016 19:05, Robert@ne ha scritto:

>
> Ciao Angelo.
>
> Ho creato l'host virtuale come da tue istruzioni. Ho dato il comando arp ed ho
ricevuto
> regolare risposta. Ho provato a lanciare il WOL dal sito che mi indichi ma
niente da fare.
> Non vorrei che dipendesse dall'impostazione sul Forwarding delle porte. I
parametri che mi
> chiede sono questi:
>
> Applicazione, Protocollo, Source Net, Dalla Porta, Indirizzo IP,Alla Porta,
Abilita
>
>
> Ho provato in vari modi non avendo le idee chiare ma nulla da fare. Ho
incrociato di tutto
> ma non si vuole svegliare sto ******* Quello che mi fa arrabbiare è che da
LAN tutto
> funziona, perciò mi fa pensare che la strada da percorrere sia breve, ma non
la trovo!
>
> Rob.

impostazioni per il Forwarding:
Applicazione: e' solo un riferimento mnemonico, chiamalo WOL o come vuoi
Protocollo: UDP
Source Net 0.0.0.0
Dalla porta: 9 (la stessa impostata sul sito)
Alla porta: 9
Abilita: spuntato

Come diagnostica puoi abilitare il LOG (Sicurezza Firewall Gestione Log),
imposti
dettaglio Alto e abiliti tutto. Cosi' vedi se i pacchetti arrivano al router e
se vengono
accettati.

Ciao.
angelo
Robert@ne 30 Apr 2016 21:30
Il 30/04/2016 19:35, angelo ha scritto:

>
> impostazioni per il Forwarding:
> Applicazione: e' solo un riferimento mnemonico, chiamalo WOL o come vuoi
> Protocollo: UDP
> Source Net 0.0.0.0
> Dalla porta: 9 (la stessa impostata sul sito)
> Alla porta: 9
> Abilita: spuntato
>
> Come diagnostica puoi abilitare il LOG (Sicurezza Firewall Gestione
> Log), imposti dettaglio Alto e abiliti tutto. Cosi' vedi se i pacchetti
> arrivano al router e se vengono accettati.
>
> Ciao.
> angelo
>


Ciao Angelo.

Sto seguendo alla lettera quanto mi dici, ho attivato il LOG del
Firewall come diagnostica, ma non vedo nulla di nuovo. Il Source Net
l'ho settato come da tue indicazioni, il parametro Indirizzo IP che tu
non menzioni, ho impostato il fatidico 89.150.36.235. E se l'IP pubblico
non mi fosse stato attivato per esempio?! Mi è stata data conferma
dell'attivazione, o il settaggio è veramente così arduo, oppure a questo
punto mi sorge un dubbio sull'attivazione...

Rob.
angelo 30 Apr 2016 22:03
Il 30/04/2016 21:30, Robert@ne ha scritto:
> Il 30/04/2016 19:35, angelo ha scritto:
>
>>
>> impostazioni per il Forwarding:
>> Applicazione: e' solo un riferimento mnemonico, chiamalo WOL o come vuoi
>> Protocollo: UDP
>> Source Net 0.0.0.0
>> Dalla porta: 9 (la stessa impostata sul sito)
>> Alla porta: 9
>> Abilita: spuntato
>>
>> Come diagnostica puoi abilitare il LOG (Sicurezza Firewall Gestione
>> Log), imposti dettaglio Alto e abiliti tutto. Cosi' vedi se i pacchetti
>> arrivano al router e se vengono accettati.
>>
>> Ciao.
>> angelo
>>
>
>
> Ciao Angelo.
>
> Sto seguendo alla lettera quanto mi dici, ho attivato il LOG del Firewall come
> diagnostica, ma non vedo nulla di nuovo. Il Source Net l'ho settato come da
tue
> indicazioni, il parametro Indirizzo IP che tu non menzioni, ho impostato il
fatidico
> 89.150.36.235. E se l'IP pubblico non mi fosse stato attivato per esempio?! Mi
è stata
> data conferma dell'attivazione, o il settaggio è veramente così arduo,
oppure a questo
> punto mi sorge un dubbio sull'attivazione...
>
> Rob.
>
Giusto, ho dimenticato l'indirizzo IP per il Forwarding: devi mettere lo stesso
del record
ARP cioe' 192.168.1.x; l'indirizzo 89.150.36.235 e' quello di destinazione che
imposti nel
sito per lanciare la prova.
Se sei d'accordo posso provare una richiesta http o ftp sul tuo indirizzo IP
pubblico
cosi' puoi vedere sul log se ti risulta.

angelo
Robert@ne 30 Apr 2016 22:08
Il 30/04/2016 22:03, angelo ha scritto:

>>
> Giusto, ho dimenticato l'indirizzo IP per il Forwarding: devi mettere lo
> stesso del record ARP cioe' 192.168.1.x; l'indirizzo 89.150.36.235 e'
> quello di destinazione che imposti nel sito per lanciare la prova.
> Se sei d'accordo posso provare una richiesta http o ftp sul tuo
> indirizzo IP pubblico cosi' puoi vedere sul log se ti risulta.
>
> angelo


Certo, fai pure. Che ne dici se ti scrivo in privato via mail?


Grazie.

Rob
angelo 30 Apr 2016 22:16
Il 30/04/2016 22:08, Robert@ne ha scritto:
> Il 30/04/2016 22:03, angelo ha scritto:
>
>>>
>> Giusto, ho dimenticato l'indirizzo IP per il Forwarding: devi mettere lo
>> stesso del record ARP cioe' 192.168.1.x; l'indirizzo 89.150.36.235 e'
>> quello di destinazione che imposti nel sito per lanciare la prova.
>> Se sei d'accordo posso provare una richiesta http o ftp sul tuo
>> indirizzo IP pubblico cosi' puoi vedere sul log se ti risulta.
>>
>> angelo
>
>
> Certo, fai pure. Che ne dici se ti scrivo in privato via mail?
>
>
> Grazie.
>
> Rob

Se nessun altro e' interessato sono d'accordo, il mio indirizzo e' valido.
Ora faccio alcune prove.

angelo
Robert@ne 30 Apr 2016 22:21
Il 30/04/2016 22:16, angelo ha scritto:

>
> Se nessun altro e' interessato sono d'accordo, il mio indirizzo e' valido.
> Ora faccio alcune prove.
>
> angelo


Ottimo.

Se ne vengo a capo farò un riassunto della situazione nel caso venga
utile a qualcun altro.

Rob.

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Reti locali | Tutti i gruppi | it.comp.reti.locali | Notizie e discussioni reti locali | Reti locali Mobile | Servizio di consultazione news.