Reti locali
 

Info VPN...

Albyus 11 Mag 2017 13:06
ciao a tutti,
sono nuovo con le VPN, ho configurato tra pc di casa e il nas a lavoro
una VPN con prootocollo openvpn.
Ho installato Openvpn sul pc e sono riuscito a farli connettere.
e adesso?
come faccio a vedere i ******* Se voglio fare accedere un software da casa
rtramite VPN ad un ******* specifico (ad esempio un ******* db di un
magazzino) come faccio?
Grazie a tutti!!
Alberto
GabrieleMax 11 Mag 2017 13:49
Il 11/05/2017 13:06, Albyus ha scritto:
> ciao a tutti,
> sono nuovo con le VPN, ho configurato tra pc di casa e il nas a lavoro
> una VPN con prootocollo openvpn.

Molto nebulosa come descrizione.

> Ho installato Openvpn sul pc e sono riuscito a farli connettere.
> e adesso?

Openvpn lavora in modalità client/server, ci sono certificati ssl, si
usa il protocollo udp o tcp, si inserisce un range di indirizzi, si
mettono delle regole di routing per limitare l'accesso a parte o a tutta
la rete, si imposta una crittografia dei dati e cosi' via.

> come faccio a vedere i ******* Se voglio fare accedere un software da casa
> rtramite VPN ad un ******* specifico (ad esempio un ******* db di un
> magazzino) come faccio?

Mi sa che te l'hai fatta troppo semplice, vorresti costruire un'auto
sapendo solo di un auto cambiare le gomme! :)

> Grazie a tutti!!
> Alberto

Prego!
Saluti!
GabrieleMax
Albyus 11 Mag 2017 13:57
>> ciao a tutti,
>> sono nuovo con le VPN, ho configurato tra pc di casa e il nas a lavoro
>> una VPN con prootocollo openvpn.
>
> Molto nebulosa come descrizione.
>
>> Ho installato Openvpn sul pc e sono riuscito a farli connettere.
>> e adesso?
>
> Openvpn lavora in modalità client/server, ci sono certificati ssl, si
> usa il protocollo udp o tcp, si inserisce un range di indirizzi, si
> mettono delle regole di routing per limitare l'accesso a parte o a tutta
> la rete, si imposta una crittografia dei dati e cosi' via.
>
>> come faccio a vedere i ******* Se voglio fare accedere un software da casa
>> rtramite VPN ad un ******* specifico (ad esempio un ******* db di un
>> magazzino) come faccio?
>
> Mi sa che te l'hai fatta troppo semplice, vorresti costruire un'auto
> sapendo solo di un auto cambiare le gomme! :)


hai voglia di aiutarmi a capire come fare? :-)
GabrieleMax 11 Mag 2017 14:32
> hai voglia di aiutarmi a capire come fare? :-)

Il n.g. non è una ONLUS, si risponde per quel che si sa e per il tempo
che uno riesce a dedicare alle risposte, pagando c'è chi realizza tutto
quello che tu vorresti fare perchè non è cosi' b*****e tirar su una VPN
in maniera sicura! :)

Perdona la risposta un po' "ruvida" però imho prima di tutto ed in ogni
ambito vanno descritte le esigenze poi e solo poi si trovano le
soluzioni migliori!

Se devi comprare un'auto nuova la discriminante maggiore è quante ore ci
passi dentro e quanti km in media fai tutti i giorni, ad esempio se fai
l'agente di commercio si parte escludendo le citycars! :D

Saluti.
GabrieleMax
Albyus 11 Mag 2017 14:43
Il 11/05/2017 14.32, GabrieleMax ha scritto:
>> hai voglia di aiutarmi a capire come fare? :-)
>
> Il n.g. non è una ONLUS, si risponde per quel che si sa e per il tempo
> che uno riesce a dedicare alle risposte, pagando c'è chi realizza tutto
> quello che tu vorresti fare perchè non è cosi' b*****e tirar su una VPN
> in maniera sicura! :)
>
> Perdona la risposta un po' "ruvida" però imho prima di tutto ed in ogni
> ambito vanno descritte le esigenze poi e solo poi si trovano le
> soluzioni migliori!
>
> Se devi comprare un'auto nuova la discriminante maggiore è quante ore ci
> passi dentro e quanti km in media fai tutti i giorni, ad esempio se fai
> l'agente di commercio si parte escludendo le citycars! :D
>
> Saluti.
> GabrieleMax

A) ti ho solo chiesto se avessi avuto voglia di aiutarmi a capire

B) evidentemente sei un professionista quindi è giusto che tu venga pagato

C) i newsgroup come i forum, per quello che ne so servono anche ad
aiutarsi, mi è capitato spesso di farlo a me con altri e "perderci" del
tempo

D) nessuno nasce imparato

E)grazie lo stresso e buona giornata a te !!

saluti
Alberto
Luca Amicone 11 Mag 2017 14:48
Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:

> hai voglia di aiutarmi a capire come fare?


Diciamo che fino ad ora hai implementato solo i primi livelli ISO/OSI (sui
quali ti consiglio di farti una cultura.. ;-).
In pratica, ora hai solo creato un c*****e attraverso far parlare "a basso
livello" il NAS e il tuo pc. Ora devi implementare un colloquio a livello
più elevato. Parti dal "ping" intanto, per vedere se almeno a livello IP
dal pc raggiungi il NAS. Poi magari prova a raggiungerlo in http://
<IPDelNas> e vedi che succede..
--
Luca Amicone
--
"Risoluzione dei problemi relativi all'indirizzamento TCP/IP per LAN e RAS"
http://support.microsoft.com/?id=128647
ObiWan 11 Mag 2017 15:15
:: On Thu, 11 May 2017 12:48:59 -0000 (UTC)
:: (it.comp.reti.locali)
:: <of1mjr$vki$1@lamicone.motzarella.org>
:: Luca Amicone <l.amicone@almaviva.it> wrote:

> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>
>> hai voglia di aiutarmi a capire come fare?
>
>
> Diciamo che fino ad ora hai implementato solo i primi livelli ISO/OSI
> (sui quali ti consiglio di farti una cultura.. ;-).

Ciao Luchino :D ! Ben (ri)trovato !!

> In pratica, ora hai solo creato un c*****e attraverso far parlare "a
> basso livello" il NAS e il tuo pc. Ora devi implementare un colloquio
> a livello più elevato. Parti dal "ping" intanto, per vedere se almeno
> a livello IP dal pc raggiungi il NAS. Poi magari prova a raggiungerlo
> in http:// <IPDelNas> e vedi che succede..

E poi, volendo, si potrebbero fare dei giochini con "hosts" (e, volendo
esagerare, LMhosts ;D)

ciaoo :)
Albyus 11 Mag 2017 15:35
Il 11/05/2017 14.48, Luca Amicone ha scritto:
> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>
>> hai voglia di aiutarmi a capire come fare?
>
>
> Diciamo che fino ad ora hai implementato solo i primi livelli ISO/OSI (sui
> quali ti consiglio di farti una cultura.. ;-).
> In pratica, ora hai solo creato un c*****e attraverso far parlare "a basso
> livello" il NAS e il tuo pc. Ora devi implementare un colloquio a livello
> più elevato. Parti dal "ping" intanto, per vedere se almeno a livello IP
> dal pc raggiungi il NAS. Poi magari prova a raggiungerlo in http://
> <IPDelNas> e vedi che succede..
>

ciao Luca grazie del supporto, si il nas lo "pingo" senza problemi
avendo già configurato il servizio dyndns, e tranquillamente lo gestisco
da remoto in tutte le sue parti...
Albyus 11 Mag 2017 15:46
Il 11/05/2017 14.48, Luca Amicone ha scritto:
> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>
>> hai voglia di aiutarmi a capire come fare?
>
>
> Diciamo che fino ad ora hai implementato solo i primi livelli ISO/OSI (sui
> quali ti consiglio di farti una cultura.. ;-).
> In pratica, ora hai solo creato un c*****e attraverso far parlare "a basso
> livello" il NAS e il tuo pc. Ora devi implementare un colloquio a livello
> più elevato. Parti dal "ping" intanto, per vedere se almeno a livello IP
> dal pc raggiungi il NAS. Poi magari prova a raggiungerlo in http://
> <IPDelNas> e vedi che succede..
>

dimenticavo che essendo sul NAS una OPENvpn ho già reindirizzato sul
router del nas la porta UDP 1194...
ObiWan 11 Mag 2017 15:46
:: On Thu, 11 May 2017 15:35:55 +0200
:: (it.comp.reti.locali)
:: <of1pbt$40j$1@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

> Il 11/05/2017 14.48, Luca Amicone ha scritto:
>> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>>
>>> hai voglia di aiutarmi a capire come fare?
>>
>>
>> Diciamo che fino ad ora hai implementato solo i primi livelli
>> ISO/OSI (sui quali ti consiglio di farti una cultura.. ;-).
>> In pratica, ora hai solo creato un c*****e attraverso far parlare "a
>> basso livello" il NAS e il tuo pc. Ora devi implementare un
>> colloquio a livello più elevato. Parti dal "ping" intanto, per
>> vedere se almeno a livello IP dal pc raggiungi il NAS. Poi magari
>> prova a raggiungerlo in http:// <IPDelNas> e vedi che succede..

> ciao Luca grazie del supporto, si il nas lo "pingo" senza problemi
> avendo già configurato il servizio dyndns, e tranquillamente lo
> gestisco da remoto in tutte le sue parti...

Ok, quindi, una volta avviata la VPN, se da prompt lanci

ipconfig /all

dovresti avere un nuovo indirizzo IP corrispondente al tunnel VPN tra
te e l'endpoint remoto; me lo confermi ?
Albyus 11 Mag 2017 15:50
Il 11/05/2017 15.46, ObiWan ha scritto:
> :: On Thu, 11 May 2017 15:35:55 +0200
> :: (it.comp.reti.locali)
> :: <of1pbt$40j$1@virtdiesel.mng.cu.mi.it>
> :: Albyus <none@none.it> wrote:
>
>> Il 11/05/2017 14.48, Luca Amicone ha scritto:
>>> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>>>
>>>> hai voglia di aiutarmi a capire come fare?
>>>
>>>
>>> Diciamo che fino ad ora hai implementato solo i primi livelli
>>> ISO/OSI (sui quali ti consiglio di farti una cultura.. ;-).
>>> In pratica, ora hai solo creato un c*****e attraverso far parlare "a
>>> basso livello" il NAS e il tuo pc. Ora devi implementare un
>>> colloquio a livello più elevato. Parti dal "ping" intanto, per
>>> vedere se almeno a livello IP dal pc raggiungi il NAS. Poi magari
>>> prova a raggiungerlo in http:// <IPDelNas> e vedi che succede..
>
>> ciao Luca grazie del supporto, si il nas lo "pingo" senza problemi
>> avendo già configurato il servizio dyndns, e tranquillamente lo
>> gestisco da remoto in tutte le sue parti...
>
> Ok, quindi, una volta avviata la VPN, se da prompt lanci
>
> ipconfig /all
>
> dovresti avere un nuovo indirizzo IP corrispondente al tunnel VPN tra
> te e l'endpoint remoto; me lo confermi ?
>
>

si, sotto scheda ethernet2 ho descrizione tap adapter con ip
10.8.0.6(preferenziale)
dovrebbe essere questo
Albyus 11 Mag 2017 15:51
Il 11/05/2017 15.46, ObiWan ha scritto:
> :: On Thu, 11 May 2017 15:35:55 +0200
> :: (it.comp.reti.locali)
> :: <of1pbt$40j$1@virtdiesel.mng.cu.mi.it>
> :: Albyus <none@none.it> wrote:
>
>> Il 11/05/2017 14.48, Luca Amicone ha scritto:
>>> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>>>
>>>> hai voglia di aiutarmi a capire come fare?
>>>
>>>
>>> Diciamo che fino ad ora hai implementato solo i primi livelli
>>> ISO/OSI (sui quali ti consiglio di farti una cultura.. ;-).
>>> In pratica, ora hai solo creato un c*****e attraverso far parlare "a
>>> basso livello" il NAS e il tuo pc. Ora devi implementare un
>>> colloquio a livello più elevato. Parti dal "ping" intanto, per
>>> vedere se almeno a livello IP dal pc raggiungi il NAS. Poi magari
>>> prova a raggiungerlo in http:// <IPDelNas> e vedi che succede..
>
>> ciao Luca grazie del supporto, si il nas lo "pingo" senza problemi
>> avendo già configurato il servizio dyndns, e tranquillamente lo
>> gestisco da remoto in tutte le sue parti...
>
> Ok, quindi, una volta avviata la VPN, se da prompt lanci
>
> ipconfig /all
>
> dovresti avere un nuovo indirizzo IP corrispondente al tunnel VPN tra
> te e l'endpoint remoto; me lo confermi ?
>
>

forse cosi è meglio...

Scheda Ethernet Ethernet 2:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : TAP-Windows Adapter V9
Indirizzo fisico. . . . . . . . . . . : 00-FF-42-45-2E-69
DHCP abilitato. . . . . . . . . . . . : Sì
Configurazione automatica abilitata : Sì
Indirizzo IPv6 locale rispetto al collegamento . :
fe80::a531:7934:7edf:39c2%39(Preferenziale)
Indirizzo IPv4. . . . . . . . . . . . : 10.8.0.6(Preferenziale)
Subnet mask . . . . . . . . . . . . . : 255.255.255.252
Lease ottenuto. . . . . . . . . . . . : giovedì 11 maggio 2017 15:27:52
Scadenza lease . . . . . . . . . . . : venerdì 11 maggio 2018 15:27:51
Gateway predefinito . . . . . . . . . :
Server DHCP . . . . . . . . . . . . . : 10.8.0.5
IAID DHCPv6 . . . . . . . . . . . : 654376770
DUID Client DHCPv6. . . . . . . . :
00-01-00-01-1F-AC-BA-61-E8-11-32-4F-4B-20
Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS su TCP/IP . . . . . . . . . . : Attivato
ObiWan 11 Mag 2017 16:01
:: On Thu, 11 May 2017 15:51:30 +0200
:: (it.comp.reti.locali)
:: <of1q95$4ja$2@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

> Il 11/05/2017 15.46, ObiWan ha scritto:
>> :: On Thu, 11 May 2017 15:35:55 +0200
>> :: (it.comp.reti.locali)
>> :: <of1pbt$40j$1@virtdiesel.mng.cu.mi.it>
>> :: Albyus <none@none.it> wrote:
>>
>>> Il 11/05/2017 14.48, Luca Amicone ha scritto:
>>>> Il Thu, 11 May 2017 13:57:26 +0200, Albyus ha scritto:
>>>>
>>>>> hai voglia di aiutarmi a capire come fare?
>>>>
>>>>
>>>> Diciamo che fino ad ora hai implementato solo i primi livelli
>>>> ISO/OSI (sui quali ti consiglio di farti una cultura.. ;-).
>>>> In pratica, ora hai solo creato un c*****e attraverso far parlare
>>>> "a basso livello" il NAS e il tuo pc. Ora devi implementare un
>>>> colloquio a livello più elevato. Parti dal "ping" intanto, per
>>>> vedere se almeno a livello IP dal pc raggiungi il NAS. Poi magari
>>>> prova a raggiungerlo in http:// <IPDelNas> e vedi che succede..
>>
>>> ciao Luca grazie del supporto, si il nas lo "pingo" senza problemi
>>> avendo già configurato il servizio dyndns, e tranquillamente lo
>>> gestisco da remoto in tutte le sue parti...
>>
>> Ok, quindi, una volta avviata la VPN, se da prompt lanci
>>
>> ipconfig /all
>>
>> dovresti avere un nuovo indirizzo IP corrispondente al tunnel VPN
>> tra te e l'endpoint remoto; me lo confermi ?
>>
>>
>
> forse cosi è meglio...
>
> Scheda Ethernet Ethernet 2:
>
> Suffisso DNS specifico per connessione:
> Descrizione . . . . . . . . . . . . . : TAP-Windows Adapter V9
> Indirizzo fisico. . . . . . . . . . . : 00-FF-42-45-2E-69
> DHCP abilitato. . . . . . . . . . . . : Sì
> Configurazione automatica abilitata : Sì
> Indirizzo IPv6 locale rispetto al collegamento . :
> fe80::a531:7934:7edf:39c2%39(Preferenziale) Indirizzo
> IPv4. . . . . . . . . . . . : 10.8.0.6(Preferenziale) Subnet
> mask . . . . . . . . . . . . . : 255.255.255.252 Lease
> ottenuto. . . . . . . . . . . . : giovedì 11 maggio 2017 15:27:52
> Scadenza lease . . . . . . . . . . . : venerdì 11 maggio 2018
> 15:27:51 Gateway predefinito . . . . . . . . . : Server
> DHCP . . . . . . . . . . . . . : 10.8.0.5 IAID
> DHCPv6 . . . . . . . . . . . : 654376770 DUID Client
> DHCPv6. . . . . . . . : 00-01-00-01-1F-AC-BA-61-E8-11-32-4F-4B-20
> Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%1
> fec0:0:0:ffff::2%1 fec0:0:0:ffff::3%1
> NetBIOS su TCP/IP . . . . . . . . . . : Attivato


Ok, a questo punto... supponiamo che la scheda di rete "normale" al
momento abbia un IP tipo "172.24.10.152" e che la tua rete "di casa"
invece utilizzi una subnet "192.168.1.0/24"; quello che dovrai fare è
"istruire" lo stack di rete in modo che inoltri il traffico destinato
alla tua subnet domestica verso il GW remoto della VPN; in breve, nel
caso di cui sopra, da un prompt amministratore

route add 192.168.1.0 mask 255.255.255.0 10.8.0.5

fatto quanto sopra, dovresti essere in grado di "pingare" gli hosts
della tua LAN; ammesso che l'endpoint che usi a casa per la OpenVPN sia
anche il default gateway della rete :)
Albyus 11 Mag 2017 16:07
> Ok, a questo punto... supponiamo che la scheda di rete "normale" al
> momento abbia un IP tipo "172.24.10.152" e che la tua rete "di casa"
> invece utilizzi una subnet "192.168.1.0/24"; quello che dovrai fare è
> "istruire" lo stack di rete in modo che inoltri il traffico destinato
> alla tua subnet domestica verso il GW remoto della VPN; in breve, nel
> caso di cui sopra, da un prompt amministratore
>
> route add 192.168.1.0 mask 255.255.255.0 10.8.0.5
>
> fatto quanto sopra, dovresti essere in grado di "pingare" gli hosts
> della tua LAN; ammesso che l'endpoint che usi a casa per la OpenVPN sia
> anche il default gateway della rete :)

fatto

Microsoft Windows [Versione 10.0.14393]
(c) 2016 Microsoft Corporation. Tutti i diritti sono riservati.

C:\WINDOWS\system32>route add 192.168.1.0 mask 255.255.255.0 10.8.0.5
OK

C:\WINDOWS\system32>
Albyus 11 Mag 2017 16:10
> fatto quanto sopra, dovresti essere in grado di "pingare" gli hosts
> della tua LAN; ammesso che l'endpoint che usi a casa per la OpenVPN sia
> anche il default gateway della rete :)

sembra la strada giusta... :-)

C:\WINDOWS\system32>ping 10.8.0.6

Esecuzione di Ping 10.8.0.6 con 32 byte di dati:
Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128

Statistiche Ping per 10.8.0.6:
Pacchetti: Trasmessi = 4, Ricevuti = 4,
Persi = 0 (0% persi),
Tempo approssimativo percorsi andata/ritorno in millisecondi:
Minimo = 0ms, Massimo = 0ms, Me***** = 0ms

C:\WINDOWS\system32>
ObiWan 11 Mag 2017 16:32
:: On Thu, 11 May 2017 16:10:01 +0200
:: (it.comp.reti.locali)
:: <of1rbr$5hn$2@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

>> fatto quanto sopra, dovresti essere in grado di "pingare" gli hosts
>> della tua LAN; ammesso che l'endpoint che usi a casa per la OpenVPN
>> sia anche il default gateway della rete :)
>
> sembra la strada giusta... :-)
>
> C:\WINDOWS\system32>ping 10.8.0.6
>
> Esecuzione di Ping 10.8.0.6 con 32 byte di dati:
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>
> Statistiche Ping per 10.8.0.6:
> Pacchetti: Trasmessi = 4, Ricevuti = 4,
> Persi = 0 (0% persi),
> Tempo approssimativo percorsi andata/ritorno in millisecondi:
> Minimo = 0ms, Massimo = 0ms, Me***** = 0ms
>
> C:\WINDOWS\system32>
>

Ora fai qualche prova e poi, se tutto funge, invece di ripetere tutte
le volte il comando "route" dai un'occhiata a come fare in modo che la
tabella di routing venga aggiornata "in automatico" quando attivi la
tua openvpn :)
ObiWan 11 Mag 2017 16:38
:: On Thu, 11 May 2017 16:32:19 +0200
:: (it.comp.reti.locali)
:: <20170511163219.00002a88@eternal-september.org>
:: ObiWan <obiwan@mvps.org> wrote:

> :: On Thu, 11 May 2017 16:10:01 +0200
> :: (it.comp.reti.locali)
> :: <of1rbr$5hn$2@virtdiesel.mng.cu.mi.it>
> :: Albyus <none@none.it> wrote:
>
>>> fatto quanto sopra, dovresti essere in grado di "pingare" gli
>>> hosts della tua LAN; ammesso che l'endpoint che usi a casa per la
>>> OpenVPN sia anche il default gateway della rete :)
>>
>> sembra la strada giusta... :-)
>>
>> C:\WINDOWS\system32>ping 10.8.0.6
>>
>> Esecuzione di Ping 10.8.0.6 con 32 byte di dati:
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>>
>> Statistiche Ping per 10.8.0.6:
>> Pacchetti: Trasmessi = 4, Ricevuti = 4,
>> Persi = 0 (0% persi),
>> Tempo approssimativo percorsi andata/ritorno in millisecondi:
>> Minimo = 0ms, Massimo = 0ms, Me***** = 0ms
>>
>> C:\WINDOWS\system32>
>>
>
> Ora fai qualche prova e poi, se tutto funge, invece di ripetere tutte
> le volte il comando "route" dai un'occhiata a come fare in modo che la
> tabella di routing venga aggiornata "in automatico" quando attivi la
> tua openvpn :)

hint

https://unix.stackexchange.com/questions/91071/openvpn-push-a-route-to-client-with-a-different-gateway

:)
Albyus 11 Mag 2017 16:56
>> C:\WINDOWS\system32>
>>
>
> Ora fai qualche prova e poi, se tutto funge, invece di ripetere tutte
> le volte il comando "route" dai un'occhiata a come fare in modo che la
> tabella di routing venga aggiornata "in automatico" quando attivi la
> tua openvpn :)

ok, ho riavviato, riconnesso la VPN e senza aver di nuovo dato il
comando route, il 10.8.0.6 lo pinga ancora... solo che in risorse del
computer non riesco a vedere niente, se non le solite cose, devo per
caso fare altro?
ObiWan 11 Mag 2017 17:19
:: On Thu, 11 May 2017 16:56:01 +0200
:: (it.comp.reti.locali)
:: <of1u24$8lr$1@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

>>> C:\WINDOWS\system32>
>>>
>>
>> Ora fai qualche prova e poi, se tutto funge, invece di ripetere
>> tutte le volte il comando "route" dai un'occhiata a come fare in
>> modo che la tabella di routing venga aggiornata "in automatico"
>> quando attivi la tua openvpn :)

> ok, ho riavviato, riconnesso la VPN e senza aver di nuovo dato il
> comando route, il 10.8.0.6 lo pinga ancora... solo che in risorse del
> computer non riesco a vedere niente, se non le solite cose, devo per
> caso fare altro?

supponendo che (es.) uno dei computer sulla tua rete (remota) abbia
indirizzo IP 10.8.0.8 e che quel computer abbia delle condivisioni
attive, prova ad aprire esplora risorse e poi nella barra indirizzi
immetti \\10.8.0.8 e premi invio
Albyus 11 Mag 2017 17:27
>> ok, ho riavviato, riconnesso la VPN e senza aver di nuovo dato il
>> comando route, il 10.8.0.6 lo pinga ancora... solo che in risorse del
>> computer non riesco a vedere niente, se non le solite cose, devo per
>> caso fare altro?
>
> supponendo che (es.) uno dei computer sulla tua rete (remota) abbia
> indirizzo IP 10.8.0.8 e che quel computer abbia delle condivisioni
> attive, prova ad aprire esplora risorse e poi nella barra indirizzi
> immetti \\10.8.0.8 e premi invio

ecco, stai attento che adesso mi perdo sulle stupidate..
come faccio a sapere sulla rete remota il mio nas che ip avrebbe?
Albyus 11 Mag 2017 17:42
Il 11/05/2017 17.19, ObiWan ha scritto:
> :: On Thu, 11 May 2017 16:56:01 +0200
> :: (it.comp.reti.locali)
> :: <of1u24$8lr$1@virtdiesel.mng.cu.mi.it>
> :: Albyus <none@none.it> wrote:
>
>>>> C:\WINDOWS\system32>
>>>>
>>>
>>> Ora fai qualche prova e poi, se tutto funge, invece di ripetere
>>> tutte le volte il comando "route" dai un'occhiata a come fare in
>>> modo che la tabella di routing venga aggiornata "in automatico"
>>> quando attivi la tua openvpn :)
>
>> ok, ho riavviato, riconnesso la VPN e senza aver di nuovo dato il
>> comando route, il 10.8.0.6 lo pinga ancora... solo che in risorse del
>> computer non riesco a vedere niente, se non le solite cose, devo per
>> caso fare altro?
>
> supponendo che (es.) uno dei computer sulla tua rete (remota) abbia
> indirizzo IP 10.8.0.8 e che quel computer abbia delle condivisioni
> attive, prova ad aprire esplora risorse e poi nella barra indirizzi
> immetti \\10.8.0.8 e premi invio
>

come non detto, fatto.. sono andato per prove ed ho trovato 10.8.0.1,
grazie davvero par la tua pazienza e disponibilità !!!
acc 11 Mag 2017 20:42
Il 11/05/2017 16.10, Albyus ha scritto:

> C:\WINDOWS\system32>ping 10.8.0.6
>
> Esecuzione di Ping 10.8.0.6 con 32 byte di dati:
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>
> Statistiche Ping per 10.8.0.6:
> Pacchetti: Trasmessi = 4, Ricevuti = 4,
> Persi = 0 (0% persi),
> Tempo approssimativo percorsi andata/ritorno in millisecondi:
> Minimo = 0ms, Massimo = 0ms, Me***** = 0ms
>
> C:\WINDOWS\system32>

Qualcosa non quadra, come fai ad avere RTT=0 con un ping in remoto?
Albyus 12 Mag 2017 08:50
Il 11/05/2017 20.42, acc ha scritto:
> Il 11/05/2017 16.10, Albyus ha scritto:
>
>> C:\WINDOWS\system32>ping 10.8.0.6
>>
>> Esecuzione di Ping 10.8.0.6 con 32 byte di dati:
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>> Risposta da 10.8.0.6: byte=32 durata<1ms TTL=128
>>
>> Statistiche Ping per 10.8.0.6:
>> Pacchetti: Trasmessi = 4, Ricevuti = 4,
>> Persi = 0 (0% persi),
>> Tempo approssimativo percorsi andata/ritorno in millisecondi:
>> Minimo = 0ms, Massimo = 0ms, Me***** = 0ms
>>
>> C:\WINDOWS\system32>
>
> Qualcosa non quadra, come fai ad avere RTT=0 con un ping in remoto?

ehhhh qui non so cosa dirti, ma apparentemente funziona tutto alla
perfezione... :-)
ObiWan 12 Mag 2017 08:50
:: On Thu, 11 May 2017 17:42:48 +0200
:: (it.comp.reti.locali)
:: <of20pr$b82$1@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

> Il 11/05/2017 17.19, ObiWan ha scritto:
>> :: On Thu, 11 May 2017 16:56:01 +0200
>> :: (it.comp.reti.locali)
>> :: <of1u24$8lr$1@virtdiesel.mng.cu.mi.it>
>> :: Albyus <none@none.it> wrote:
>>
>>>>> C:\WINDOWS\system32>
>>>>>
>>>>
>>>> Ora fai qualche prova e poi, se tutto funge, invece di ripetere
>>>> tutte le volte il comando "route" dai un'occhiata a come fare in
>>>> modo che la tabella di routing venga aggiornata "in automatico"
>>>> quando attivi la tua openvpn :)
>>
>>> ok, ho riavviato, riconnesso la VPN e senza aver di nuovo dato il
>>> comando route, il 10.8.0.6 lo pinga ancora... solo che in risorse
>>> del computer non riesco a vedere niente, se non le solite cose,
>>> devo per caso fare altro?
>>
>> supponendo che (es.) uno dei computer sulla tua rete (remota) abbia
>> indirizzo IP 10.8.0.8 e che quel computer abbia delle condivisioni
>> attive, prova ad aprire esplora risorse e poi nella barra indirizzi
>> immetti \\10.8.0.8 e premi invio

> come non detto, fatto.. sono andato per prove ed ho trovato 10.8.0.1,
> grazie davvero par la tua pazienza e disponibilità !!!

Fai una cosa; apri un prompt comandi "admin" poi scrivi

pushd %SYSTEMROOT%\System32\drivers\etc

attrib -r hosts

notepad hosts

ora, in notepad, vai in fondo al ******* aggiungi una riga vuota quindi
scrivi

10.8.0.1 nasremoto

premi invio due volte in modo da lasciare una riga vuota anche sotto
(giusto per sicurezza), salva e chiudi notepad

attrib +r hosts

popd

exit

ora, in esplora risorse, prova ad immettere nella barra degli indirizzi

\\nasremoto

:)
Albyus 12 Mag 2017 13:52
>> come non detto, fatto.. sono andato per prove ed ho trovato 10.8.0.1,
>> grazie davvero par la tua pazienza e disponibilità !!!
>
> Fai una cosa; apri un prompt comandi "admin" poi scrivi
>
> pushd %SYSTEMROOT%\System32\drivers\etc
>
> attrib -r hosts
>
> notepad hosts
>
> ora, in notepad, vai in fondo al ******* aggiungi una riga vuota quindi
> scrivi
>
> 10.8.0.1 nasremoto
>
> premi invio due volte in modo da lasciare una riga vuota anche sotto
> (giusto per sicurezza), salva e chiudi notepad
>
> attrib +r hosts
>
> popd
>
> exit
>
> ora, in esplora risorse, prova ad immettere nella barra degli indirizzi
>
> \\nasremoto
>
> :)

si, però adesso non esagerare altrimenti qualcuno potrebbe dire che il
ng non è una onlus..
a parte gli scherzi, grazie davvero!!! stasera provo, anche se, sembra
funzionare tutto alla grande... tra l'altro con fibra da ambo le parti
non ci sono problemi neanche di velocità ! :-D
ObiWan 12 Mag 2017 14:42
:: On Fri, 12 May 2017 13:52:14 +0200
:: (it.comp.reti.locali)
:: <of47lg$1ou$1@virtdiesel.mng.cu.mi.it>
:: Albyus <none@none.it> wrote:

> si, però adesso non esagerare altrimenti qualcuno potrebbe dire che
> il ng non è una onlus.. a parte gli scherzi, grazie davvero!!!

Nessun problema; d'altronde è quello che gli NG "erano una volta" e
comunque quello che /dovrebbero/ essere; ad ogni modo...

> stasera provo, anche se, sembra funzionare tutto alla grande... tra
> l'altro con fibra da ambo le parti non ci sono problemi neanche di
> velocità ! :-D

più che altro, se riesci a trovare il tempo, documentati meglio sulla
configurazione di OVPN ed in particolare sulla possibilità di fare
"push" dei parametri (inclusi quelli di routing)

Che altro... ah, si, spero tu stia usando una versione recente di OVPN,
mica per altro, ma viste le vuln relative a cifre ed hash, sarebbe il
caso di accertarsi chee la connessione sia effettivamente sicura, che
so, un TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 andrebbe benone :) (e no,
quello che significa quanto sopra non te lo spiego, mica sono una
onlus :D !!)

Links
Giochi online
Dizionario sinonimi
Leggi e codici
Ricette
Testi
Webmatica
Hosting gratis
   
 

Reti locali | Tutti i gruppi | it.comp.reti.locali | Notizie e discussioni reti locali | Reti locali Mobile | Servizio di consultazione news.